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DEVELOPMENT SYSTEM KIT CONTENTS 
An evaluation board (EVAL-ADuCM322EBZ) that facilitates 

performance evaluation of the device with a minimum of 
external components 

An Analog Devices, Inc., Segger J-Link OB emulator (USB-
SWD/UART-EMUZ) 

1 USB cable 
1 installation DVD 

INTRODUCTION 
The ADuCM322 is an on-chip, dual-die stack system designed 
for diagnostic control on fixed wavelength laser optical module 
applications. It features a 16-bit (12-bit accurate) multichannel 
SAR analog-to-digital converter (ADC), an ARM® Cortex™-M3 
processor, eight voltage digital-to-analog converters (DACs), 
four current output DACs, and flash/EE memory packaged in 
a 6 mm × 6 mm, 96-ball CSP_BGA package. 

GENERAL DESCRIPTION 
The ADuCM322 development system evaluates the 
ADuCM322. This quick start guide introduces the support 
features and tools supplied with the evaluation kit. In addition, 
this guide shows and describes how to connect the evaluation 
hardware.  

The getting started guide works as a tutorial, providing 
instructions on how to download third party evaluation software 
tools. Instructions are also provided on how to load code examples 
supplied with the software tools. 

This guide gives users the ability to generate and download user 
code for use in unique end system requirements. 

TYPICAL SETUP OF THE EVAL-ADUCM322EBZ AND J-LINK OB EMULATOR 
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Figure 1. 
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GETTING STARTED 
SOFTWARE INSTALLATION PROCEDURES 
Perform the steps described in this section before plugging any 
of the USB devices into the PC. 

1. Close all open applications. 
2. Insert the installation DVD into a DVD drive.  
3. Double-click ADuCM310_32x.exe and follow the on-screen  

instructions. A menu displays installation options as shown 
in Figure 2. 
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Figure 2. Installation Options 

The following components install by default: 

 FTDI drivers for the evaluation board. 
 Example code and function sets for most peripherals. 
 An Elves.exe application to easily choose functions from 

the provided function sets followed by choosing from the 
function parameters. 

The following components are optional installations: 

 Keil development tools (a compiler, debugger, and 
programming tools). The Keil software Revision v5.14 is 
used. Analog Devices added a patch to this revision of the 
MDK460 tools to support the ADuCM322. 

 IAR development tools (a compiler, debugger, and 
programming tools). 

 Segger J-Link drivers. These are the drivers for the J-Link 
emulator. 

The J-Link software is selected by default in the installation menu 
shown in Figure 2. It is advised to leave it selected. The J-Link 
software automatically installs the J-Link serial port driver. Select 
Install USB Driver for J-Link-OB with CDC as shown in Figure 3. 
If that step is missed, run JLinkCDCInstaller_V1.2b.exe 
located in the ADuCM322\Segger folder. 
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Figure 3. Installing Link Software 

If using the IAR tools, the entire contents of the supplied arm 
directory (for example, C:\ADuCM322…\IAR\IAR_M320_ 
Patch0.2.zip\arm) must be copied to the IAR tools directory 
(for example, C:\Program Files\IAR Systems\ Embedded 
Workbench 6.5 Kickstart\arm). 

Future updates may be available from the Analog Devices  
FTP site. 

KEIL μVISION5 
The Kiel μVision5 integrated development environment (IDE) 
integrates all the tools necessary to edit, assemble, and debug 
code. The fastest way to get started is to open an existing Kiel 
μVision5 project by following these steps: 

 

1. In Keil μVision5, select Project > Open Project. 
2. Browse to the folder where the ADuCM322 software is 

installed (such as, C:\ADuCM322...). 
3. Open the file DIO.uvproj in the folder 

code\ADuCM322\examples\DIO. This file launches an 
example project. 

4. Compile and download to the device. 
5. To run the example code, press RESET on the board or 

enter debug mode and select Run. 
6. When running, the red LED marked DISPLAY on the 

board flashes. 

http://www.analog.com/ADuCM322?doc=ADuCM322_Getting_Started_Guide_UG-910.pdf
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IAR EWARM 
The IAR EWARM IDE integrates all the tools necessary to edit, 
assemble, and debug code. The fastest way to get started is to 
open an existing workspace by following these steps:  

1. Open the IAR tools from C:\Program Files (x86)\IAR 
Systems\Embedded Workbench 6.5\common\ 
binIarIdePm.exe. 

2. Within the IAR IDE, click File > Open > workspace and 
open a workspace provided by Analog Devices (for example, 
C:\ADuCM322…\code\ADuCM322\examples\ 
DIO\DIO.eww). 

3. Compile and download the code to the device using 
Project > Rebuild All and then to Project > Download 
Active Application. 

4. Click No if a pop-up window appears identifying an 
unknown device. 

5. To run the code, press RESET on the board or enter debug 
mode and select Go. 

6. When running, the red LED marked DISPLAY on the 
board flashes. 

ELVES.EXE 
Elves.exe is an application that chooses functions from the 
provided function sets and function parameters. Elves.exe can 
be integrated into the Keil μVision5 and IAR tools under the 
tool menus. For instructions, run Elves.exe (for example, at 
C:\ADuCM322…\Software Tools\Elves\Elves.exe) and press the 
F1 key or click the Help button.  

EVALUATION BOARD SETUP PROCEDURES 
Assembling and Connecting the Hardware 

Do not plug in the USB cable before the software is installed. 
Use the following steps to connect the hardware: 

1. Insert the USB cable provided between the PC and the J-Link 
OB emulator (emulator shown in Figure 4). 

2. The red LED (LED1) flashes until initialization of the drivers 
is complete. 

3. Details for installation of the drivers may appear on the 
screen. Allow the installation of these drivers to complete 
as they provide a virtual communication port on the PC that 
allows the evaluation board to appear as a virtual serial com-
munication port to the UART port of the ADuCM322 device. 

4. If using the virtual serial communication port to the UART, 
ensure Jumpers LK3 and LK5 are in place on the board (see 
Figure 5). If using the UART on the J8 connector, remove 
Jumpers LK3 and LK5 to prevent contention. 

5. Plug the 10-pin DIL connector of the J-Link OB emulator 
into the EVAL-ADuCM322EBZ.  

6. To power up the evaluation board, apply a voltage between 
4 V and 5.5 V to the J5 connector or a voltage between 
4.7 V and 6.2 V to the J14 connector. The green POWER 
LED turns on. 
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Figure 4. Emulator, Top View 
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Figure 5. J-Link OB Connection Details 
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Evaluating the MSDIO Download Mode 

To evaluate the MSDIO download mode using the MDIOWSD 
software, use the SUB-20 multi interface USB adapter (not 
included). This allows connectivity between the ADuCM322 
evaluation board and PC via the MDIOWSD software. The 
following is the procedure to download code to the device using 
the MSDIO interface.  

1. Connect the relevant pins of the SUB-20 board to the pins 
of the EVAL-ADuCM322EBZ as detailed in Table 1. 

Table 1. Pin Connection Guide 
EVAL-ADuCM322EBZ Pins SUB-20 Pins 
DGND J6-10  
1.2 V  J6-9 
MDIO J6-7 
MCK J6-1 

2. On the SUB-20 board, ensure 
a. Pin J7 is set to 3.3 V. 
b. Pins JP1, JP2 JP3, JP4, and JP5 are set to connect Pin 1 

to Pin 2. 
c. Pin JP6 is set to connect Pin 2 to Pin 3. 

3. Connect the USB cable from the PC to the SUB-20 board and 
run C:\ADuCM322…\Software Tools\ 
MDIOWSD\MDIOWSD.exe 

4. Click Browse and navigate to a specific code to download. 
5. To download the code, select Program and Verify, Start 

and follow the instructions. 

 

 

 

 

 

 

 

ESD Caution  
ESD (electrostatic discharge) sensitive device. Charged devices and circuit boards can discharge without detection. Although this product features patented or proprietary protection 
circuitry, damage may occur on devices subjected to high energy ESD. Therefore, proper ESD precautions should be taken to avoid performance degradation or loss of functionality. 

Legal Terms and Conditions 
By using the evaluation board discussed herein (together with any tools, components documentation or support materials, the “Evaluation Board”), you are agreeing to be bound by the terms and conditions 
set forth below (“Agreement”) unless you have purchased the Evaluation Board, in which case the Analog Devices Standard Terms and Conditions of Sale shall govern. Do not use the Evaluation Board until you 
have read and agreed to the Agreement. Your use of the Evaluation Board shall signify your acceptance of the Agreement.  This Agreement is made by and between you (“Customer”) and Analog Devices, Inc. 
(“ADI”), with its principal place of business at One Technology Way, Norwood, MA 02062, USA. Subject to the terms and conditions of the Agreement, ADI hereby grants to Customer a free, limited, personal, 
temporary, non-exclusive, non-sublicensable, non-transferable license to use the Evaluation Board FOR EVALUATION PURPOSES ONLY. Customer understands and agrees that the Evaluation Board is provided 
for the sole and exclusive purpose referenced above, and agrees not to use the Evaluation Board for any other purpose. Furthermore, the license granted is expressly made subject to the following additional 
limitations: Customer shall not (i) rent, lease, display, sell, transfer, assign, sublicense, or distribute the Evaluation Board; and (ii) permit any Third Party to access the Evaluation Board. As used herein, the term 
“Third Party” includes any entity other than ADI, Customer, their employees, affiliates and in-house consultants. The Evaluation Board is NOT sold to Customer; all rights not expressly granted herein, including 
ownership of the Evaluation Board, are reserved by ADI. CONFIDENTIALITY. This Agreement and the Evaluation Board shall all be considered the confidential and proprietary information of ADI. Customer may 
not disclose or transfer any portion of the Evaluation Board to any other party for any reason. Upon discontinuation of use of the Evaluation Board or termination of this Agreement, Customer agrees to 
promptly return the Evaluation Board to ADI. ADDITIONAL RESTRICTIONS. Customer may not disassemble, decompile or reverse engineer chips on the Evaluation Board. Customer shall inform ADI of any 
occurred damages or any modifications or alterations it makes to the Evaluation Board, including but not limited to soldering or any other activity that affects the material content of the Evaluation Board. 
Modifications to the Evaluation Board must comply with applicable law, including but not limited to the RoHS Directive. TERMINATION. ADI may terminate this Agreement at any time upon giving written notice 
to Customer. Customer agrees to return to ADI the Evaluation Board at that time. LIMITATION OF LIABILITY. THE EVALUATION BOARD PROVIDED HEREUNDER IS PROVIDED “AS IS” AND ADI MAKES NO 
WARRANTIES OR REPRESENTATIONS OF ANY KIND WITH RESPECT TO IT. ADI SPECIFICALLY DISCLAIMS ANY REPRESENTATIONS, ENDORSEMENTS, GUARANTEES, OR WARRANTIES, EXPRESS OR IMPLIED, RELATED 
TO THE EVALUATION BOARD INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTY OF MERCHANTABILITY, TITLE, FITNESS FOR A PARTICULAR PURPOSE OR NONINFRINGEMENT OF INTELLECTUAL 
PROPERTY RIGHTS. IN NO EVENT WILL ADI AND ITS LICENSORS BE LIABLE FOR ANY INCIDENTAL, SPECIAL, INDIRECT, OR CONSEQUENTIAL DAMAGES RESULTING FROM CUSTOMER’S POSSESSION OR USE OF 
THE EVALUATION BOARD, INCLUDING BUT NOT LIMITED TO LOST PROFITS, DELAY COSTS, LABOR COSTS OR LOSS OF GOODWILL. ADI’S TOTAL LIABILITY FROM ANY AND ALL CAUSES SHALL BE LIMITED TO THE 
AMOUNT OF ONE HUNDRED US DOLLARS ($100.00). EXPORT. Customer agrees that it will not directly or indirectly export the Evaluation Board to another country, and that it will comply with all applicable 
United States federal laws and regulations relating to exports. GOVERNING  LAW. This Agreement shall be governed by and construed in accordance with the substantive laws of the Commonwealth of 
Massachusetts (excluding conflict of law rules). Any legal action regarding this Agreement will be heard in the state or federal courts having jurisdiction in Suffolk County, Massachusetts, and Customer hereby 
submits to the personal jurisdiction and venue of such courts. The United Nations Convention on Contracts for the International Sale of Goods shall not apply to this Agreement and is expressly disclaimed. 

©2016 Analog Devices, Inc. All rights reserved. Trademarks and  
 registered trademarks are the property of their respective owners. 
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